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PART I: GETTING STARTED
ABOUT THE TASK SHEETS

The Task Sheets have been assembled to help facilitate hands-on learning in Director, while giving
valuable tips and creating a long term resource.  Students should have their Task Sheets with them every
day, and keep them for future Director courses.  These sheets have been in a perpetual state of maintenance
and upgrades since their introduction in January of 2001.  They have constantly improved with the input of
many instructors and especially the students who have used them in the past.

In general, each Task Sheet will require the student to thoroughly follow instructions.  Depending
on the lessons, students will be required to create Director files per instructions, then show the completed
file(s) to the instructor for course credit.  Certain exercises will be accompanied by a pre-built Director file
that the student must acquire.  In most cases, the Task Sheets will also have a final section with follow-up
questions that students are expected to fill out as if taking an open-book quiz.  Wrong answers on questions
result in lost points (points are also deducted for exercises that are skipped or done incorrectly).

**Note: The images in all Task Sheets are screen shots acquired from the Mac OSX platform only.

DIRECTOR’S PROFESSIONAL USES

Director’s most marketable feature is its ability to import a multitude of media types (graphics,
sound, video, Flash SWF files, etc.) while allowing users to manipulate it manually or with internal
programming to create enhanced interactive presentations. Another attractive feature is that those
presentations can be delivered on CD or DVD as self-running applications that do not need Director on the
host computer.  Director can also create shockwave files for playback through the internet.

Job postings rarely ask for someone who is simply a Director expert.  Instead, it is often requested
along with other Macromedia software such as Flash and web applications, but it is also common to see it
listed with programming jobs, or even media related companies who produce digital video.  Director has
managed to thrive in some of the following niches:

Promotional CDs for companies and products
Kiosks at trade shows or other public conventions
Educational or training software
Children’s interactive games and activities
Interactive Presentations added to music CDs for added marketability
Interactive high school yearbooks
Interactive presentations added to Hollywood DVDs for computer playback.

All of these niches benefit from Director projects that can combine animation, sound, video, graphic
design, and advanced programming to create a dynamic interactive media experience.  Some Director
products may require the efforts of entire teams of contributors.  Designers, animators, researchers,
programmers, testers, audio and video specialists, and even acting or musical talent may be required to
compile a thorough presentation.

Director’s unique combination of capabilities has yet to be seriously challenged by any other
software on the market.  It’s powerful presence continues to gain popularity, as evidenced by years of
Director presentations that continue to appear in cutting edge media.

Task Sheet 1:  About the Task Sheets and Director’s professional uses
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OVERVIEW OF THE PROCESS FOR BUILDING A DIRECTOR PROJECT

STEP 1: Planning and Construction of External Components

STEP 2: Assimilating and building the Content Inside of Director
Once inside of Director, you will begin assimilating content into your
project in one of two ways, either by importing external files, or by using
Director’s internal tools to create content:

As each new component is imported or created
internally, it is filed in the Cast.  Any individual
item inside of the Cast is referred to as a
Cast Member.

STEP 3: Presentation Construction
Visual Cast Members can be dragged off of the cast
onto either the Score or the Stage.  At that point they
become a Sprite.  Sprites can then be manipulated
as keyframed animations, scripted for functionality,
or simply arranged on the Stage for visual layout.
(This Task Sheet will offer more thorough coverage of the Cast, Score, Stage, Sprites, and other
significant windows used in Director in following pages.)

STEP 4: Exporting Final Products
The file types you will eventually create depends on how or where you intend to show your Director
presentation. While you are still building the project in Director,
it is called a Movie.  To export a
standard desktop application, you
would export a Projector.  For
the web we export Shockwave
files.  Each format has its own
technical concerns.

Task Sheet 1: Overview of Steps in building a Director project

The first step is concept development.  Before any project is initiated, there should be a
comprehensive phase of preparation such as conceptual sketches, flow charts, and research.
As with any detailed project--good planning should always supersede actual production.

The next step is the creation and gathering of actual content.  Depending on the project, the
content might include graphics, sound, video, text, and any other elements that are essential.
All media types should be optimized and prepared for formats best suitable for the project.

Director’s Internal tools:
Paint window
Vector Window
Text window
Field Window
Tool Palette
Lingo Scripts
Shockwave 3-D

Imported media (Recognizable formats for Director):
Graphics: png, psd, bmp, gif(animated or bitmapped), jpeg, pict, tif
**does not import Adobe Illustrator or EPS files***
Audio Formats:  aif, wav, MP3, SWA, AU
Video: Quicktime, Real Player (Other formats can be viewed with
third party plug-ins)
Shockwave:  Director can import Flash swf files and with plug-ins
can also import 3-D wireframes built in Maya and Studio Max

CAST

SCORE STAGE

MOVIE
PROJECTOR

SHOCKWAVE
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Behavior: This is a nick-name for any scripting that has been added to an object, such as a sprite.  The
script tells the object what to do (how to behave) so its script is also referred to as its ‘behavior’.

Cast: The Cast is the window where all individual components are filed during construction of a Director
project.  Each graphic, media file, text box and script that you add by importing or creating material
internally will appear in the Cast.

Cast Member: The name for any individual component (such as an individual graphic) while it is stored in
the Cast window.

Lingo: Director’s comprehensive internal programming language that allows users to add simple scripts to
objects like button commands, along with complicated scripts that might be used in an interactive game.

Movie: When a project is still under construction inside of Director, the cumulative file that is saved is
called a ‘movie’.  The appropriate extension for a Director movie is .dir
the image at right shows what a Director movie icon looks like:

Projector: A read-only, self-running version of a Director project that is exported once the project is at a
satisfactory level of completion.  Projectors are actually applications (just like Photoshop or Microsoft
Word) but they launch what you constructed in your Director movie.  They can not be opened with
Director, but they also do not need Director to be present on the host machine since they are self-contained
files.  This makes them ideal for creating presentations that can be viewed independently from any other
software. Projectors can only function in the platform that they were created in, so a projector created on a
MacIntosh would be a Mac version, and would not operate in Windows, and a Windows version would not
operate on a MacIntosh system.  On the Windows(PC) platform, a projector’s extension is .exe

Score:  The Director window that represents the linear-time aspect of a project.  It uses a system of frames
to indicate where a project is currently playing during elapsed footage over time.  It is a critical window for
creating the chronological order of the presentation, as well as creating keyframed animation or
destinations in a navigation system

Script: Any compilation of Lingo code.  A script can be very brief, or very saturated with commands.
Either way, it is still referred to as a ‘script’.  If an object has a behavior on it, we could also say that it has
been scripted.  (‘Scripting’ is a verb for the act of adding code.)

Shockwave: Format for any Director project that is to be exported for internet playback.  A Shockwave
version of a Director project can be displayed in a browser window over the web. The proper extension
for a Shockwave file is .dcr

Sprite: Any visual Cast Member that has been placed on the Score or on the Stage.  On the Stage, the
visual version of a sprite is represented as it would appear in the current frame.  On the Score, it is
displayed as a line within a channel, representing how many frames it occupies over time.

Stage: The Stage is the screen where the visual representation of your project appears.  Whatever you see
on your Stage during playback while authoring, is what the user will see in the final project.

Task Sheet 1: Director Terminology

BASIC TERMINOLOGY
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Although Director has a built in Paint window, most designers would find it too basic and
rudimentary to create eye-catching graphics.  In most cases, Photoshop will be the ideal software for
manipulating images into perfection.  Unfortunately, Photoshop does not automatically package up your
graphic creations for perfect transfer into Director.   There are three common challenges that will arise:

1). Images should always be converted to RGB format.

2). Some non-rectangular images need to be imported into Director as “cut out” forms with an alpha
channel surrounding it and occurring inside of the form as well.  If not prepared correctly, a graphic
like this will have distorted edges once it is displayed on the Stage in Director.

3). As with web design, images created for a Director project need to be measured in advance by
pixel dimensions. Director allows an image to be scaled in its Paint Window, but often with
detrimental results.  It is also possible to scale a Sprite to the desired size on the Stage, but doing
that can drain available memory and bog down Director’s playback performance.

Here are solutions for #2 and #3:

#2). Assuring visual quality for cut-out images:

Suppose you had a cut out image in
Photoshop like the one shown at right.
If you wanted to display this image
over a background so that the back
image was visible through all areas
that are alpha channel on this statue,
you would do the following:

Step 1: Crop the image close to its
edges—it is undesirable to have a
large surrounding area once it is in
Director.

Step 2: Make sure that the image
is on its own transparent layer, and
is isolated in its own document,
(a multi-layer Photoshop document will not cooperate with this process.)

Step 3: Save this document in the PNG format.  PNG is the absolute best format for exporting a
non-rectangular image while preserving transparent alpha channels.

Step 4: While importing the PNG into Director, a dialogue box (covered later in this sheet) will
ask you what bit depth the image should be imported at.  Always leave the bit depth at 24 or 32.
A lower setting will eliminate the alpha channel.

Task Sheet 1: Preparation of graphic files

PREPARING GRAPHICS



6

Examine the two images below.  This demonstrates a comparison between the statue image as a PNG
(displayed on the left,) and the statue image imported as a flattened, bitmapped format (displayed on the
right).  You can certainly see the difference. The bitmapped version has white pixels on its edges, while
the PNG has retained excellent edge quality

#3). Confirming image size in Photoshop before importing it into Director:

As mentioned on the previous page, it is not a good idea to import graphics at large dimensions.  They take
up more memory, and if used in a Director presentation, they can hinder performance as well.  To avoid
setbacks, always check the size of your image.

Task Sheet 1: Preparation of graphic files

(Close-up magnified at 200%)

PNG

Photoshop often shows images at a size
that will fit within your monitor, but the
display size may be quite smaller than
the actual dimensions.  Unless the zoom
percentage at the top of the image’s
window is 100%, you are not seeing the
true size that it will be on screen.

The safest method for confirming true dimensions in Photoshop is
to go to File>Image Size which will open a dialogue box.  In the
top portion, the image size should be expressed in current pixel
dimensions. The example below is much too large—a standard
size for a Director Stage is 800 X 600 pixels, which would be
dwarfed by this graphic.  In this scenario, we would have to
reduce the graphic’s dimensions considerably.  It would be very
unwise to import this into Director then scale it down as a sprite.
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PART II: WORKING INSIDE DIRECTOR
Now that we’ve covered some preliminary topics, it is time to explore essential functions and

windows inside of Director itself.  In Part 2 we will elaborate on the functionality of Director’s essential
windows (the Cast, the Stage, the Score, and the Property Inspector).  Each section will begin with a shot of
Director’s toolbar to show you where the shortcut icons are for accessing each window.  Before we
examine all of the windows, let’s start with the process of importing external files into Director:

RECOGNIZABLE FORMATS:

• Graphics: png, psd, bmp, gif(animated or bitmapped), jpeg, pict, tif
**Note: Director does not import Adobe Illustrator or EPS files***

• Audio Formats:  aif, wav, MP3, SWA, AU

• Video: Quicktime, Real Player (Other formats can be viewed with third party plug-ins)

• Shockwave:  Director can import Flash swf files and with plug-ins can also import 3-D wireframes
that have been built in Maya and 3-D Studio Max

SOME CRITICAL FACTS ABOUT IMPORTING FILES:

• By default, when you import files such as graphics, sounds, and .swf files, they are embedded into
your Cast so it is not necessary to keep the original files with your Director project.  (The only
exception to this rule is Quicktime videos, which are always imported as an established link to the
video file itself—this will be covered again in Task Sheet #4)

• Files may be imported as links to the original outside files, but then those files must always be
available to your Director project at the path name established during the time of import.  This
means that you should establish a folder for the linked files that will always accompany your
project.  If the folder is absent or the path name is altered the Director project will open dialogue
boxes asking where to find the missing files.  Linked files in your Cast will be identifiable because
the icon in the lower right corner will appear to have an earmarked tab as shown below:

Standard Imported           Linked
     Graphic File      Graphic File

Task Sheet 1: Importing Files into Director

IMPORTING FILES
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PROCESS FOR IMPORTING EXTERNAL FILES:
(Also covered in the course text on pages 77 – 80)

Step 1: To import a file, go to File>Import

Step 2: When the Import dialogue box appears
(as shown to the right) Browse to the
folder(s) with the file(s) you wish to
import into Director.

Step 3: Select the file(s) you want by clicking
on their name in the browse menu in the
top half of the dialogue box

Step 4: Click on ‘Add’ and the file’s name will
appear in the list in the lower half

      Step 5: Unless your project requires linked media, Step 6: Click on “Import
make sure the import process is set to “Standard” to officially import the file(s)

Once you have clicked on “Import”, Director proceeds to interpret and download the files into its
Cast.  For graphic formats, you will most likely encounter the Image Options dialogue box.(shown below)
where you will be asked to confirm desired settings. Here is an explanation of each option:

Color Depth: This defines what bit depth the
graphic will be imported at.  It’s usually OK
to keep it at the level of the graphic.  If it needs
to be changed, this can be done later inside
of Director (which will be covered in a later
Task Sheet).  If you are bringing in a PNG file
with alpha channels, it must remain at 32 bits.
(24 on a PC).

Palette: If the image is grayscaled, or was
assembled with an indexed palette (such as a web 216 palette) Director allows you to choose whether to
keep the reference palette or remap it to a conventional Mac or Windows palette.

Trim White Space: If your graphic contains any white borders or white areas adjacent to its edges, you
may wish to disable this option, since it will indeed slice off residual white space.

Dither: This setting can usually be skipped.  It only applies if you need Director to dither colors from a
standard palette to match those in a separate or specialized palette.

Same Settings for Remaining Images: This helps if you are importing several graphics at once.  If you do
not check this box, the Image Options dialogue box will pop up for each graphic as you import them all.

**Note: GIF files get a dialogue box where you can select to import it as a still bitmap or animated**

Task Sheet 1: Importing Files into Director
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CRITICAL FACTS ABOUT THE CAST WINDOW IN DIRECTOR:

• Everything added to a Director project (imported or built internally) is filed into the Cast.

• Any single element inside of the Cast is called a Cast Member.  Any Cast Member without a name
can only be referenced by its Cast Member number. It is a good idea to develop the habit of giving
Cast Members individual names as they are added.  It helps for organization, but it is also an
important reference method when adding Lingo scripts later.  To avoid contradictions in scripts,
never duplicate Cast Member names.  Always give each Cast Member a unique name. To name a
Cast Member, select it then in the field at the top of the Cast Window type the name

• All Cast Members have identifying icons that clarify what type of file they are (graphic, sound, etc.)
For a definition of each icon see page 38 of the course text.

• The default Cast is called the ‘Internal’ Cast, but it is possible to create an external Cast, or to create
multiple Casts within one movie for filing purposes.  None of our exercises require these
specialized Casts, but for thorough coverage of these processes see page 448 & 449 of the textbook.

DISPLAY OPTIONS FOR THE CAST WINDOW:

The Cast itself can be viewed in two visual styles—as a list (which is the default setting) or as a
grid of thumbnails.  Use the “Cast View Style” button to switch back and forth

In list view mode,
you can specify
which criteria is
used to display
the Cast Members
in order (such as
alphabetic or
numerical.)

MANIPULATING CAST MEMBERS IN THE CAST WINDOW

In general, Cast Members can be manually re-arranged, copied and pasted elsewhere in the Cast, or
removed by simply selecting the Cast Member and deleting it.

Holding down the COMMAND key allows you to select specific Cast Members within the entire range.

The SHIFT key allows you to select a range of Cast Members

Task Sheet 1: The Cast Window

THE CAST
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*Property Inspector

CRITICAL FACTS ABOUT THE STAGE WINDOW IN DIRECTOR:

• The Stage is the visual representation of your project.  It is what the user will see and interact with in
your final project.

• The dimensions and color of the Stage can be set in the *Property Inspector under the “Movie” tab.
(Select the Stage before opening the Property Inspector or the ‘Movie’ tab won’t be an option)

• The Stage is measured in units of pixels.  It’s coordinate system originates in the upper left corner.  You
should commit this coordinate system to memory now because future exercises will refer to it.  If your
Stage was set to dimensions of 800 X 600, the diagram below shows where your coordinates would be.

Task Sheet 1: Overview of the Stage

THE STAGE

                     X Axis                    8000

Y
Axis

600
Zoom

Control

Built-in Playback  Control Panel
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CRITICAL FACTS ABOUT THE SCORE WINDOW IN DIRECTOR:

• The Score contains three different zones (shown below).  The Sprite Toolbar reports the values of a
sprite’s properties when you select it.  The Effects Channels are useful for different purposes.  The
final zone is the visible channels in the bottom of the Score where all of your visual content will be
arranged for playback. (See diagram on next page)

• The background to foreground layering system in Director is based on the channel numbers in the
Score.  A sprite in Channel 1 will always be the extreme background.  Sprites in higher numbered
channels will be in the foreground, and if they are superimposed, the sprite with the higher channel
number will appear in front of  any sprite(s) with lower channel numbers.

• The Score is referenced by channels (horizontal rows) and by frames (vertical rows).  The gray bar
with numbers on it in the middle of the Score is the frame number indicator.  The red vertical line with
the pink box is the playback head.  It indicates what frame is the current frame, both while authoring
and during live playback. (See diagram on next page)

HOW TO DISPLAY THE SCORE’S SEPARATE ZONES:

This is what the Score looks like by default, or
when all of its auxiliary panels are closed.

To open the very top section, (the Sprite
Toolbar), make sure that the Score is the
active window in Director, then go to
View > Sprite Toolbar

To open the Effects Channels panel, use
the button on the right side of the Score
window: (Close up below)

Task Sheet 1: Overview of the Score Window

THE SCORE
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DOCKING

The Score can also be combined with the Cast as one large window by docking the Cast:

To Dock the Cast into the Score window,
click the grab zone on the left side of the Cast’s
title bar and drag it anywhere on top of the Score   To Undock the Cast from the Score, use the Cast’s
window then let go.   grab zone and drag it out of the Score window.

THE INTERFACE OF THE SCORE WINDOW

Task Sheet 1: Overview of the Score Window

Score's Zoom control

Tempo channel
Color Palette channel
Transition channel

Audio
channels

Marker channel

Scripting channel

Effects Channels (also in course text, pg 12 to 17)

Frames

Channels

Frame
numbers

Playback Head

Swatches for color-coding selected sprites

Sprite (Score version)
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SPRITES
CRITICAL FACTS ABOUT SPRITES

• When a visual Cast Member is dragged from the Cast onto either the Score or the Stage, it
simultaneously creates a Sprite in both windows. There are two versions of Sprites.  Visual Sprites
are shown as toggle boxes on the Stage, while linear time Sprites are represented in channels on the
Score as rectangular boxes with end points:

On the Stage, Sprites are displayed
with overlay boxes beneath them
by default.  The boxes offer a small
summary of the sprite’s properties
and if the bottom line has content, Sprites on the Score can be manipulated

it means the sprite is also scripted.  To deactivate or in several ways to establish property
reactivate the boxes go to View > Sprite overlay. settings and keyframes over time.

• Sprites do not have names.  Instead they are referred to by the number of the channel that they
occupy on the Score.  If a Sprite is placed into channel 5 it is referred to as Sprite 5 in any of the
frames it occupies along the duration of the movie.

• Remember that a sprite in a higher numbered channel will appear to be in front of all sprites in the
channels with lower numbers, and channel one is the extreme background layer.

ASSIGNING THE INK SETTING OF A SPRITE

When you bring a non-rectangular image onto the Stage, you will notice that a white box
encapsulates the image.  There are 3 ink settings that we will use in standard production, and you can use
the Score or Property Inspector to change ink settings on a selected sprite.

1) Copy: This is the default ink setting.  Photos or other rectangular images can be left at this setting. Other
shapes will appear inside of a white box on this setting.

2) Matte: This setting will eliminate the white box and display only the shape itself.  If the shape/object
has areas of white inside of itself, they will be preserved with the Matte setting.

3) Background Transparent: This setting will eliminate all white from any graphic sprite.  White is
Director's default alpha channel color.  If a sprite's ink is set
to Background Transparent, any white in the graphic will
become a transparent alpha channel.

There are many other ink settings available in the ink menu,
but the three above are the most standard.  The others have
specific or experimental purposes

Task Sheet 1:  Examining a Sprite
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AUTHORING TIPS FOR WORKING WITH SPRITES IN THE SCORE
(covered in the in-class demo)

• Sprites can be copied and pasted elsewhere on the Score

• Sprites can be moved vertically and horizontally about the Score if selected as an entire block.

• If you select either of a sprite’s end frames you can drag them but they will only move horizontally in
their channel, expanding or reducing the entire frame length of the sprite.

• It is possible to condense a sprite to become just one frame long.

• If a sprite is one frame long, you can re-expand it by holding down the OPTION key while dragging it
back out to the desired length of frames.

• It is possible to select multiple sprites by drawing a box around them on the Score (this also works for
their visual representations on the Stage).

• It is also possible to select entire ranges of sprites by clicking in one location, then with the SHIFT key
depressed, click in a second location.  Any sprites within the perimeter area of the two locations will
become selected.

• It is possible to select alternating sprites inside of  a range with the COMMAND key depressed

• With the OPTION key depressed, you can select very specific frames or segments of a sprite(s).

• It is possible to set how many frames long a sprite is when first generated on the Score.  Go to
File>Preferences>Sprite> enter desired number into ‘Span Duration’.

• Edit>Sprite Frames will dissect any selected sprite(s) into individual cells that can be manipulated
independently of the original sprite.  Sprite appears as several boxes.  To return to normal editing mode,
go to Edit>Entire Sprite.

• The color swatches in the lower left corner of the Score allow you to color code sprites on the Score for
better organization in your projects.

• By changing the values of various Sprite properties at different frames, you can create keyframed
motion or visual changes (See next page)

Task Sheet 1: Working with Sprites in the Score
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ANIMATING SPRITES

There are three ways to control a sprite so that it changes its position, opacity, rotation, and scale over time,
creating keyframed or animated effects:

A) By manually manipulating the Sprite on the Stage (scale, position, and rotation) at two
     different keyframes on the Sprite

B) Using the Score or Property Inspector to change settings or numerical values for properties at 
     separate keyframes on a Sprite

C) By creating Lingo commands that manipulate the Sprite.  (If you create Lingo that affects a
      certain sprite, the Lingo will take precedence over any original or keyframed Score data.)

For this  Task Sheet, we will only be covering the methods described in A and B above.  (You will
definitely see Lingo in action soon enough.)

Sprites can be selected in three ways—by the first endpoint, the last endpoint, or the entire Sprite.
In order to keyframe a sprite, you can only select one of its endpoints on the Score.  (If you select the entire
sprite then modify it, the change will be universal.) While that one endpoint is selected, you modify the
sprite.  The data for the selected keyframe will be automatically measured against the data at the opposite
keyframe and the differences will be measured over the frame duration.

endpoints endpoints

There are two basic ways to generate a keyframe onto a sprite:

1) While one of the endpoints is selected on the Score, you could switch to the Stage and
physically manipulate it on the Stage.

 2) You can type values into the property fields found in the Sprite Toolbar or the Property
Inspector, but read the note below:

**Note:  When typing numerical values in Director (MacIntosh), you must use the number keys
across the top of your keyboard—the numeric keypad on the right side of most keyboards is actually
recognized by Director as shortcut commands

It is possible to reverse the playback of keyframed data by selecting the entire keyframed sprite then going
to Modify>Reverse Sequence.

You can add a keyframe to any single frame along the duration of a Sprite by selecting the frame
then going to Insert>Keyframe.  Once a linear sprite contains more than two keyframes, expanding or
shrinking the sprite’s duration re-positions the middle keyframes proportionally to the entire span.

You can also apply enhanced keyframing options to a Sprite by going to Modify>Sprite>Tweening

Task Sheet 1: Animation through keyframing changes on a Sprite
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The Property Inspector window is a great source of information for various parts of your project.  When
you select a sprite or cast member all of its properties will become displayed in the Property Inspector.  The
Property Inspector is also where you would set features of the entire movie itself such as Stage size, Stage
color and more.  The Property Inspector can also be viewed in 2 different versions.  By selecting the 'List
View Mode' button you can alternate between an iconic view of the Property inspector, or a more thorough
listing of the properties:

List View Mode Button

Icon View       List View

It is possible to make adjustments to settings on Sprites, Cast Members, and the Stage while inside of the
Property Inspector.  If you made an adjustment to a Sprite’s settings in the Property Inspector, the Sprite
Toolbar on the Score window would also update to display your changes.

Notice that the Property Inspector window also uses a horizontal row of tabs to indicate which set of
properties are being adjusted on any given object.

Task Sheet 1: Overview of the Property Inspector

THE PROPERTY INSPECTOR
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LIBRARY PALETTE

The Library Palette contains template effects designed by Macromedia programmers for consumer use.
This feature can be useful for adding complicated interactivity to a presentation with minimal effort since
the advanced script has already been provided by Macromedia.  You will later be experimenting with this
window as part of an exercise in Task Sheet 4.

PAINT WINDOW

Although Adobe Photoshop may be the graphic software of choice for most designers, all graphics are
viewed through the Paint Window once inside of Director.  It is also possible to create new graphics inside
of Director’s Paint Window.  Although the Paint Window may not have the advanced features of
Photoshop, learning its capabilities may save you some time in production so that you can avoid repeat
visits to Photoshop to modify graphics, etc.  For thorough coverage, examine chapter 6 in the course text.

VECTOR WINDOW

Director’s Vector Window is not as advanced those you might find in Adobe Illustrator or even in
Macromedia’s Flash software.  It is better suited for any scenario where you need a simple geometric shape
or line.  There are toolbar controls for standard vector features such as stroke width and fill settings

Toolbar Gradient
Settings

Stroke setting Across Top

Fill Setting
Stroke Color
Fill Color
Background Color

Task Sheet 1: Internal Tools (Library, Paint, Vector)

DIRECTOR’S INTERNAL TOOLS

LIBRARY
PALETTE

PAINT
WINDOW

VECTOR
WINDOW

TEXT
WINDOW

SHOCKWAVE
3-D WINDOW

BEHAVIOR
INSPECTOR
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TEXT WINDOW

The Text window has familiar icons that you should recognize from many other brands of software, such
as a font selection menu, font size setting, and font styles such as Bold, Italic, and Underline.  It also
offers alignment options (Left, Center, etc.)

SHOCKWAVE 3-D

This window will not have content unless you are examining a 3-D file that you imported.  All 3-D items
built inside of Director are actually generated with Lingo commands, but you must have a 3-D Cast
Member with a name inside of your Cast so that the 3-D lingo commands know where to build the 3-D
scene.  If you wish to see your 3-D material, the movie must be in play mode and the Lingo script that
builds your 3-D scene must have been executed.  You will build a basic 3-D model later in Task Sheet 4

BEHAVIOR INSPECTOR

The Behavior Inspector provides template construction of common button features (rollover effects,
navigation, and other handy scripting elements).  Although it assembles fundamental Lingo commands
inside of a script, it is limited to a few dozen options so eventually you may have to manually add
additional commands to a behavior(script).  You will learn this window’s basic functionality in Part 3 of
this Task Sheet.

Task Sheet 1: Internal Tools (Text Window, Shockwave 3-D, Behavior Inspector

You can slide the right margin
for width sizing, as well as
create internal margins with the
sliders on the ruler.

To change the color of the Text
or its background color, you
should access the Property
Inspector window, then go to the
panel for ‘Text Inspector’.  Then
you would select the color in the
swatch boxes on the ‘Text
Inspector’ Tab.
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In the following exercise, you will simply be demonstrating your understanding of basic functions in the
Cast, Score, Stage, and the accessory windows like Paint, and Text.  You will complete the exercises below
in a Director movie that you will show the instructor for credit when you complete this entire Task sheet.
You will be graded for accuracy.  Please follow steps 1 through 10 on this page and the following page:

Step 1: Open a new Director movie.  In the Property Inspector, Set the Stage to a width of 560 pixels and a
height of 450 pixels.  Change the Stage’s color to black.

Step 2: Create the following Cast members:
>Create a box with the solid box tool in the Paint Window and name it "Box"

>Create a solid circle (use a lighter color for its fill so that it will stand out on black.)  Name
   that Cast Member “Circle”.

>Open a Text window, and type the name of your favorite movie.  (Make sure that your text is not
   black, and preferably a bright color that will stand out on the black stage.) Name this Cast
   Member “Film”

Step 3: Drag the Cast Member “Box” into channel one of the Score. Select the entire sprite and make the
following changes in either the Score or the Property inspector:

> Set its Blend(Opacity) to 60 %

> Type in numeric amounts to extend the sprite from frames 1 to 100

> Set its X coordinate to 280, and its Y coordinate to 60

> Make its width 150 and its height 80

> Now lock sprite1

Step 4: Drag the “Circle” Cast Member into channel three of the Score. Select the entire sprite and make
the following changes in either the Score or the Property inspector:

> Adjust its frame length so that it starts in Frame 10 and ends in frame 80.

> Set its X coordinate to 280, and its Y coordinate to 225.

> Set its ink to “Matte”

> Set its blend to 70%.

> Using the color-coding swatch on the Score, Color-code this Sprite so that it is orange.

(continued)

Task Sheet 1: Exercise #1, Cast, Score, and Stage functionality

EXERCISE #1: SPRITE MANIPULATION
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Step 5: Drag the “Film” Cast Member into channel five on the Score.  On the Stage, drag your text directly
over the circle.

> Set its frame length from frames 10 through 40.

> Change its ink to Background Transparent.

> Insert a keyframe at the end of the sprite so that both endpoints appear as circles.

> Select just the first keyframe on the left end of the sprite, and set its blend to 0%.

> Make sure the keyframe at the right is at 100% blend. (This keyframe will cause the text to fade
    in from frame 10 to frame 40).

> Select the entire Sprite then copy it and continue to Step 6 below.

Step 6: Paste the sprite into frame 41 on channel 5 (just to the right of the original).

> Now select the entire sprite you just pasted and go to Modify>Reverse Sequence.  (This will
reverse the keyframed sequence so that the text will fade out from frame 41 to frame 80.)

Step 7: In the Tempo channel, double-click on frame 40.  When the Tempo Properties dialogue box
appears, select the 2nd option ‘Wait’.  Set it to delay for 2 seconds.

**If you would like to test this effect, rewind the movie to Frame one and hit the ‘Play’ button on the Stage
or the Toolbar.  The text should fade in, playback should pause at frame 40 for 2 seconds, then the text
should fade out.**

Step 8: Now build 3 markers in the Marker channel as follows:
> Place one at Frame 10 and name it ‘Intro’.
> Place a second marker over frame 40 and name it ‘Delay’.
> Place a final marker at frame 100 and call it ‘Tests’

Step 9: Starting at frame 101 in the Score, add four new sprites to the Score to experiment with.  Place
them in different locations on the Stage.  On the Score, select all four sprites then set their frame length
from Frame 101 to Frame 150.  Now you will set up a keyframe on each sprite.  Using each sprite
individually, demonstrate the following keyframing techniques:

> Blend (Opacity change)
> Motion from one location to another
> Scale from large to small or small to large
> Rotation

Step 10: When you're done, save this movie with the name “Exercise1.dir”.  You will show it to the
instructor for credit when you complete the rest of the Task Sheet, so keep it with you.  For now, continue
to Part 3 of this Task Sheet.

Task Sheet 1: Exercise #1, Cast, Score, and Stage functionality
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PART III: BUILDING AN INTERACTIVE MOVIE
Now that you have had some exposure to basic functions inside of Director, we can proceed to the next
level which is creating a simple interactive presentation.  In Part 3, we will discuss the following:
• Understanding the essential concepts of designing a user-friendly interface:
• Learning how to script a sprite with the Behavior Inspector window so that it can become a button with

multiple states of functionality.
• Using the Score’s Marker channel and Scripting channel to establish a main menu plus sub-topic

destination screens in your presentation.

DESIGNING A USER-FRIENDLY INTERFACE

The term ‘User Friendly’ places great responsibility on multimedia designers who are accountable
for many aspects of a successful presentation.  Here are some scenarios they often consider:

Content structure: They must organize the overall content into logical categories.  Then they must build a
menu(s) for those categories in a structure where the user will also recognize the logical flow of content.
It is also important to maximize screen space for visual layout of the menus, content, etc.

Comprehension: Buttons themselves should visually stand out from backgrounds or surrounding graphics
and clearly communicate what the user will link to if they click on it.  A user should never have to do any
of the following when examining buttons on screen:

• Hunt for buttons because they are disguised, hidden, or obscured by other content.
• Guess what a button will do because it is not labeled.
• Interpret the meaning of a button’s label because it is vague or illegible

Legibility:  Any text that is used in a presentation for pertinent communication (such as buttons or
information passages) should be clear and easy to read.  This means that it should always have good color
contrast, generous sizing, and a legible font.

Navigation: As a user clicks on buttons, they often ‘travel’ to different parts of a presentation.  Designers
should keep the navigation controls obvious so that the user is able to freely move back and forth between
destinations inside of the presentation.  A user should never be stranded or imprisoned into watching long
segments without the choice to bypass or skip to another location.

Familiarity:  As a side note to navigation, a presentation flows much better if its controls are always
accessible through visual familiarization.  This can be achieved with color coding and consistent position.

Feedback: A multimedia presentation should always communicate back to the user.  Button functionality
should be reinforced with rollover effects, and even sound can help reinforce interactivity.  If a user clicks
to navigate to a particular topic, the screen for that topic should have a label reinforcing to the user where
they have gone.  Feedback also includes rollover effects on buttons to reinforce their functionality.

Aesthetics: How much of the user's attention span does your project require? The user's attention span is
earned--it is never automatically given. Enhancing an interface with cool graphics and interactive themes is
nice, but it should not break away from or overwhelm the essential guidelines mentioned above.

Let’s expand on these considerations by discussing the Do’s and Don’ts of interface design (next page).

Task Sheet 1: Introduction to creating an interactive presentation
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THE DO’S AND DON’T’S OF INTERFACE DESIGN

DO DON’T

By adhering to the guidelines above you can develop dynamic presentations that will still serve the needs
of any user who views your presentation.  When you build your Director project in the next course, it will
be evaluated by your instructor with all of the above items in mind.  Failure to comply with these
guidelines is a sure way to lose points on your final grade.

For the time being, you will now be tested on how well you have received the messages above.  On the
following page, you must select a client and develop graphics for a main menu and other requested content.
Your completed project will be assessed against the guidelines above and at the instructor’s discretion, you
can lose points if you commit mistakes from the ‘Don’t’ column above.  You are also accountable for
meeting client requests as stated in the passages.

Task Sheet 1: The Do’s and Don’ts of Interface Design

Develop menus and buttons that are obvious
and clearly inform the user of their function.

Hide buttons, disguise them, or leave them
unlabeled so a user has to guess what they do.

Use text that can be easily read at all times.
Remember this:  Illegible text = irrelevant text

Make text an eye-strain to read.  This includes low
contrast, tiny font sizes, and haphazard fonts.

Develop menus and buttons that are obvious
and clearly inform the user of their function.

Hide buttons, disguise them, or leave them
unlabeled so a user has to guess what they do.

Establish navigation so that it allows the user to
easily travel at will in your presentation

Trap the user into a segment, or create restrictions
like a sequence with ‘Next’ but no ‘Back’ buttons.

Place buttons in consistent locations on each
screen so that the user can easily adapt to them.

Re-arrange the buttons on each screen or change
their appearance—it’s confusing for the user.

Maximize screen space by balancing your screen
layout so that content and navigation can co-exist.

Create congested screens with busy design or
button panels that crowd the actual content itself.

Add rollover effects to buttons to reinforce their
functionality to the user.

Leave buttons in a dormant state where mouse
actions are ignored—it implies non-functionality.

Once a user navigates to a specific screen, provide
a visual indicator signifying where they are at.

Exclude helpful feedback for the user such as
visual signals about where they are currently at.

Use your skills as a designer to create visually
appealing content.  Good design never hurts.

Develop a flat, boring interface.  It devalues the
presentation and damages first impressions.

Use Director’s enhanced abilities to create an
entire theme with sound, interactivity, etc.

Make a presentation that simply clicks and
navigates to content.  It’s boring and dry.

Find a clever solution to deliver your content as a
multimedia experience, not just dry information

Rely on large passages of text to carry a project.
It defeats the purpose of using multimedia.
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Before we proceed in Director, you must first select from one of the three topics below.  Once you have
selected the topic of your choice, it is your responsibility to design a unique interface appropriate for the
topic.  This includes a background image(s), navigation bar, main menu buttons, 'return to main' buttons,
and any other features that you will incorporate for basic visual impact.  Using Photoshop and/or Director's
built-in accessories, design an interface according to the parameters of the category that you selected.
You will also need to import a sound effect for your buttons as part of this exercise.

*NOTE:  The next exercise will teach you how to swap 2 different graphics for a rollover, so you may
wish to create 2 different states of appearance for your buttons (On and Off)

(Don’t forget:  pay attention to your graphics’ dimensions.  You should be importing them at reasonable
dimensions measured by PIXELS)

TOPIC CHOICES:

Client #1: GIBRALTAR GALLEON TRAVEL AGENCY
This client specializes in luxury cruises to countries of the northern Mediterranean Sea, targeting France,
Italy, Spain, and Greece.
Logo: A classic galleon
Preferred visual theme: Classic maritime combined with cultural images
Mandatory menu items: Name, logo plus one link for each of the countries mentioned above.
Requested Subtopic content:  Brief passages and landmark shots.
Target Audience: Sophisticated travelers with an admiration of classical culture.
Purpose: Lure clientele by soliciting desirable travel packages that focus on historic landmarks.

Client #2: NATIONAL PERFORMING ARTS ASSOCIATION
This company specializes in the regional promotion of performing arts organizations such as symphonies,
operas, ballet, and theatrical production companies.
Logo: A 5-point star inside of a stage with curtains.
Preferred visual theme: Main menu should establish a sense of upper class and elegance.
Mandatory menu items: Name, logo, links for Theatrical Productions, Opera, Symphonies, and Ballet.
Requested Subtopic content:  Brief passages about each division with sample images from performances.
Target Audience: Potential venue patrons, sponsors, and donors.
Purpose: To generate revenue for those organizations who are members of NPAA.

Client #3: PETTING ZOO CHILDREN'S CLOTHING
This start up company combines the friendly presence of animal characters with their standard clothing
merchandise for children 0 to 5 years old.
Logo: Paw Print
Preferred visual theme: Primary and Secondary Colors and illustrated Animal characters.
Mandatory menu items: Name, logo, plus one link for each of these merchandise types: Clothing,
Footwear, Bedding, Stuffed Animals
Requested Subtopic content:  Brief passages and generously sized product shots.
Target Audience: Retail chain stores in North America.
Purpose: Market the Petting Zoo product line in hopes of gaining distribution at the stores.

Task Sheet 1: Exercise 2, Client Parameters

EXERCISE #2: INTERFACE DESIGN
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Once you have created the images for the topic that you selected from the previous page, the next step will
require you to go back into Director.  Open a new movie and import your images. Passages of information
can also be copied onto the clipboard and pasted directly into a text box in Director. You should also give
each of your Cast Members a distinct name for specific reference.

Step 1-A:
From the Cast, drag all of the images and text boxes for your main menu topics into frame 10 of the
Score.  (Remember that any backgrounds should occupy channel 1, buttons, etc. should be in higher
numbered channels). Make them just one frame long.

Step 1-B:
Now on the Stage, place the items into the visual arrangement that you want.

Step 1-C:
In the marker channel on the Score, add a new marker above frame 10 and call it "Main"

Step 1-D:
Now you need to apply a very basic Lingo command to the Score's scripting channel.
Double-click on the cell for the scripting channel above frame 10 and you should notice that the
Behavior Script window pops up with template script.  Add a  'go to the frame' command as
demonstrated in the diagram below:
Double-click on the cell in frame 10
inside the Scripting channel to open
a script window

Once the script window is open, you should
see the template code as displayed below.
On line 2, type ‘go to the frame’

**Memorize this process—you will use it constantly from now on**
You can now close the Script window and proceed to the next step for the exercise.

Task Sheet 1: Building a menu and adding a ‘go to the frame’ command

SETTING UP THE PRESENTATION’S MAIN MENU SCREEN
Step
1

go to the frame

EXERCISE #3: CREATE A PRESENTATION
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Step 2-A:
Copy the cell above frame 10 (where you just put your 'go to the frame' command) and paste it into
frame 30, 40, 50, and 60's Scripting channel.  (These will eventually be the destination screens that
we will navigate to from the main menu).

Step 2-B:
Drag all of the Cast Members for your first topic onto frame 30 of the Score.  Reduce the sprites so
that they are only one frame long and occupy just frame 30.  Arrange the sprites visually on the
Stage.  In the marker channel above frame 30 add a new marker and give it a name that relates to
your first subtopic (short marker names are recommended).

Step 3-B:
Repeat the same steps as 2-B for the 2nd subtopic in frame 40, the 3rd subtopic in frame 50, etc.

Step 4-B:
Place your 'Back to Main' button on the Score so that it stretches from frame 30 to frame 60.
Since it occupies all frames for the subtopics, it will always be available. Place it where you want it
to be on the Stage. We will script it later in this exercise.

Step 5-B:
Compare your Score to the diagram below.  Your Score should be laid out the same way with
content in Frame 10, 30, 40, 50, and 60 (FYI: We spaced the topics by ten frames each to keep the
Score organized).  There should be a marker over each of those frames, and a long sprite from
frame 30 to 60 as the ‘Back to Main’ button.  There should also be a ‘go to the frame’ command
over each frame with content

Checkpoint
• Make sure that all of your Cast members have distinct names
• Make sure that all of your sprites are on the Score in the appropriate frames
• Make sure that your main menu and topic screens are properly arranged visually on the Stage
• Make sure that each frame with content has an appropriately named marker above it

Once the steps above are complete, you are ready to begin scripting your presentation to link from screen to
screen, but before we move to Step 3, we will examine the Behavior Inspector (next page.)

Task Sheet 1: Assembling the topic screens and markers across the Score

SETTING UP THE SUBTOPIC CONTENT SCREENS
Step
2
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CRITICAL FACTS ABOUT THE BEHAVIOR INSPECTOR

• The Behavior Inspector is a shortcut window in Director that allows you to place template
commands onto a sprite.  Those commands can make your sprites become operational buttons in
your presentation with multiple states of functionality.

• The Behavior Inspector generates a lingo script, but only with the template commands.  If you want
more advanced Lingo effects, you would have to open the script and add them manually.

• Before you add navigation commands to a sprite with the Behavior Inspector, make sure that you
have created the necessary markers in the Score so that the marker names will be listed as options in
the Behavior Inspector's navigation submenus.

• If you want to use the Behavior Inspector to create an image swap as a  rollover effect, make sure
that you have given names to all Cast Members that will be used for all buttons.

• The Behavior inspector can be accessed many different ways:
1. The asterisk key on your numeric keypad
2. The Behavior Inspector icon on Director’s Toolbar (as shown above)
3. The Behavior Inspector icon on the Score window (left hand side)
4. From the tab docked in the Property Inspector labeled “Code: Behavior Inspector”

Once you open the Behavior Inspector it should look like this:

Task Sheet 1: Introduction to the Behavior Inspector window

THE BEHAVIOR INSPECTOR

If you do not see the three
panels as shown at right,
then use the arrows on the
left side of the Behavior
Inspector to open the
hidden sections.

Drag the black toggle lines
to re-size the panels to
proportions you want
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OVERVIEW OF ASSIGNING SCRIPTS TO SPRITES WITH THE BEHAVIOR INSPECTOR
(also covered on pages 113 - 114 in the course text)

The process for assigning a script to a sprite is simple, here is the basic sequence:

1. Select the Sprite on the Score or Stage
2. Open the Behavior Inspector
--Steps 3 through 5 are illustrated in the diagram below
3. Select ‘New Behavior’ and assign the Behavior a distinct name
4. Select the Events (mouse enter, mouse leave, mouse down, mouse up, etc.)
5. Assign an action to that event (change the sprite, play a sound, change the cursor, go to a marker, etc.)

DETERMINING IF A SPRITE HAS A BEHAVIOR ON IT

Once you have assigned a behavior to a sprite, the name of that behavior should be visible next to the
Behavior icon in that sprite’s overlay box.  Also, any selected sprite that has a behavior attached to it will
display its Behavior's name in the drop down menu for Behaviors (found just above the marker channel on
the left side of the Score’s Sprite Toolbar next to the Behavior Inspector icon.)

Now that you know what the Behavior Inspector is and how it works, go to the next page to see how you
will use it for Step 3 in your navigation exercise:

Task Sheet 1: Assigning commands to a Sprite with the Behavior Inspector

Mouse Event Definitions:
MouseUp: The instant when
the user clicks the mouse
button down then releases it
back up

MouseDown: The instant
when the mouse button is
depressed to a down state

MouseEnter: When the mouse
first rolls into the sprite zone

MouseLeave: When the
mouse rolls off the sprite zone

MouseWithin: While the
mouse is in the sprite area.

Actions are the direct
commands that you will assign
to the Event (it is possible to
assign multiple actions to one
Event).  If you wanted a button
in your presentation to link to a
separate destination, you
would use a mouseUp event
handler (at left) and then you
would choose the appropriate
Naviagtion action.

The 'Action' categories you
will be using for this
assignment are Navigation,
Sound, Sprite, and Cursor.

3

4 5
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Step 3-A: Add Behaviors to each of the 'buttons' on your main menu
On each sprite that is to become a button for your menu in frame 10, assign behaviors as follows:

• Select the sprite
• Open the Behavior Inspector
• Select ‘New Behavior’ and give the behavior a descriptive name.

Set up the rollover effects
• In ‘Events’ select ‘On mouse enter’
• In ‘Actions’, go to Cursor>Change Cursor then from the drop-down menu select ‘Finger’
• Next, select ‘Actions’ again, and go to Sprite>Change Cast Member.  In the drop-down menu, find

the name of the image that you want the button to turn into when the mouse rolls over it.
This menu is why you should name your Cast Members in advance.

• In ‘Events’ select ‘On mouse leave’
• In ‘Actions’, go to Cursor>Restore Cursor
• Select ‘Actions’ again, and go to Sprite>Change Cast Member.  In the drop-down menu, find the

name of the image that you want the button to revert to when the mouse rolls off of it.

Set up Navigation, reset the cursor on mouse click, and play a sound effect
• In ‘Events’ select ‘On mouse up’
• In ‘Actions’, go to Navigation>Marker>and then select the appropriate marker from the submenu

that appears. This menu is why you should name markers first.
• Next, go to ‘Actions’ again and select Cursor>Restore Cursor (This will reset the cursor once we

navigate. Without this, our rollover cursor changes do not get reset and the mouse remains on
screen as a finger icon.)

• Go to ‘Actions’ a third time and go to Sound>Play Cast Member.  The name of the sound file you
imported should appear in a drop-down menu.  Select it.

(Repeat the steps above for all buttons on your main menu).
**Notice that we are placing several ‘Events’ and ‘Actions’ into one Behavior.  A sprite can have
multiple behaviors assigned to it, but this can create complications.  It’s best to have just one.**

Step 3-B:  Add a Behavior to the sprite for the 'Back to Main' button
Now Script your ‘Main’ button the same way as listed above, but when you select  ‘On mouse up’
and Actions>Navigation>Marker, select ‘Main’ from the destination sub menu instead.

Step 3-C: Test the Rollovers and Navigation
Rewind the movie and play it.  The movie should freeze on frame 10 due to the 'go to the frame'
command we added.  Test your rollovers.  Now click on one of your buttons.  It should play the
sound effect and link to its respective marker and on the Score.  The playback head should now be
in the frame where the marker is located. Click on the ‘Back to Main’ button.  It should send the
playback head back to frame 10.  Test all of your menu options in frame 10 to ensure accuracy. If
you have successfully added all scripts to the right sprites and frames, the project should now freely
navigate from screen to screen while it is in play mode.  If it does not, double check that you have
followed all steps correctly.  If it does, then congratulations, you’ve just taught yourself the
essential method of creating a basic interactive presentation in Director!  Save the project.

Task Sheet 1: Adding scripts to buttons in your presentation

    APPLY LINGO COMMANDS TO SPRITES WITH THE BEHAVIOR INSPECTOR
Step
3
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So far your dazzling project should have very active buttons now, but another common feature in
interactive media is animated transitions from one screen to another.  Right now your project simply lands
in flat, restricted frames held in place with 'go to the frame' commands.

In this simple exercise, we will demonstrate that you can navigate to a keyframed segment so that
animation introduces your topic when you navigate to it

Step 4-A:
In the Score, select ALL of the sprites that you placed into frame 60. Use the frame duration fields to
extend them out on Score to Frame 75.  (Don’t forget to extend the ‘Back to Main’ button out to frame 75
as well.) Now they should look like this:

Step 4-B:
You will leave the marker over Frame 60, but drag the ‘go to the frame’ cell that is currently over Frame 60
into the Scripting channel over Frame 75.  By doing this, the playback head will not stop on Frame 60
anymore when you navigate to this marker.  Instead, it will play through the Score until it does reach Frame
75 where the ‘go to the frame’ command is now waiting.  This means you can now create an animated
transition in between the marker and the ‘go to the frame’ command.

Step 4-C:
Perform keyframes on the content spanning from Frames 60 to 75.  Once the keyframing is done, play the
movie and navigate to the topic that starts in Frame 60.  You should see the keyframes play until they stop
at frame 75.

Task Sheet 1: Navigating to a keyframed section of the Score

NAVIGATE TO A KEYFRAMED SEGMENT ON THE SCORE
Step
4
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SUMMARY

• Notice that the Behavior Inspector is closely associated with building navigational systems and button
states in Director

• The Sprites are scripted to tell the playback head to ‘go to’ a particular location, but the Score's scripts
in the destination frame tell the playback head to remain on that frame with a ‘go to the frame’ with a
Lingo channel script.

• Then the ‘Main’ button allows the user to connect back to the main menu

• With practice and experimentation, you can learn the functionality of all of the specific actions that can
be carried out under any event in the Behavior Inspector.  Note:  Although this exercise concentrated on
scripting sprites, we can apply Behavior Inspector scripts to frames on the Score as well.

• Buttons can link to markers that start an animated sequence or transition.

THE LINGO BEHIND THE SCENES

After you have tried various settings in the Behavior Inspector, you would eventually notice that although
helpful in basic navigation set up, the Behavior Inspector is still not equipped with thorough commands to
create elaborate interfaces that do advanced effects, etc.  For example, suppose you wanted a completely
different sprite to appear somewhere else on the stage when you rolled over one of your menu items.  This
requires going into the Behavior Script window and manually adding custom Lingo of your own.  We will
cover this in the next Task Sheet, but to view what kind of Lingo was created while you were assembling
this exercise, open one of your Behaviors in the Behavior Inspector and click on the Script button:

Task Sheet 1: Summary of Exercise 3
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PART IV: FOLLOW UP QUESTIONS
1)  What is the recommended format for importing images that are cut-out and require a transparent alpha
channel around them?

2)  Which channel on the Score will always display its sprites as the extreme background behind all other
sprites on the Stage?

3)  If sprite five and sprite six crossed over one another on your Stage during a keyframed segment, which
sprite would be in the foreground?

4)  Suppose you selected a sprite in your project and it is referred to as Sprite 4. What determines that
sprite’s number?

5)  Duplicating Cast Members’ names can cause problems with scripts that attempt to call the cast member
by name, and it also disrupts organization. (Circle your answer).

True False

6)  Provide an example of a user-friendly scenario, and a non user-friendly scenario:

user-friendly:

non user-friendly:

7)  If you don’t name Cast Members or build markers before using the Behavior Inspector you can still
easily  locate them in the submenus of the Behavior Inspector. (Circle your answer).

True False

8)  Write the Lingo command we type in the Score’s Scripting channel to halt the playback head at a
specified frame.

9)  Why should you always put a ‘Restore Cursor’ command on the ‘Mouse up’ part of a behavior?

10)  How do you view a Behavior’s  actual Lingo script that was generated by the Behavior Inspector?

Task Sheet 1: Follow Up Questions
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ARE YOU READY TO BE GRADED?

Here is a checklist of all items you should have ready for the instructor to view:

• Did you complete Exercise 1 on pages 19 and 20?  You should have a Director file ready for the
instructor that followed steps 1-10 (worth 1 point each).  Any skipped steps or steps done
incorrectly will result in lost points.

• Did you complete Exercise 2 on page 23?  Following the guidelines for user-friendly interface
design, you were supposed to develop an interface based on client parameters.  If you missed
certain requirements or committed mistakes as listed in the guidelines you could lose points.

• Did you complete Exercise 3 from pages 24 through 29?  For credit, your project must do all of the
following:

The buttons on your main menu should:
> Change the cursor when you roll over them
> Change the image when you roll over them
> Restore the cursor when you roll off
> Restore the original image when you roll off
> Navigate to the appropriate marker when clicked on
> Play a sound effect
> Restore the cursor when clicked

> You should have a ‘Back to Main’ button that also functions
> You should have a keyframed effect on the final topic from your menu.

If you skipped any of those steps or did them incorrectly, you may lose points.

• Did you complete all follow up questions on page 31?  These questions should be regarded as an
open book quiz.  You are accountable for answering them correctly or you will lose points.

Task Sheet 1: Final Checkpoint


